2004 XC90 - Both Brake Lights Out - Volvo Forums - Volvo Enthusiast Forum - Volvo Community - Volvo Repair
Volvo Cross Country and SUV Volvo XC50, XC60, XC70 and XC90

User Tag List

 
LinkBack Thread Tools
post #1 of 7 (permalink) Old 08-18-2009 Thread Starter
Junior Member
 
Join Date: Aug 2009
Posts: 6
Unhappy 2004 XC90 - Both Brake Lights Out

Hello,

Newbie here, but not new to playing with cars. I recently tackled replacing the fuel pump on my XC90 (known leaking issue). Everything went just fine, but I'm stuck on an issue "after" I put everything back together. I had the battery disconnected, but reconnected it to be sure the pump/lines sealed and I had no leaks. Once I was all done, I put all the seats back in and here is where the problems started. I got a SRS Alert which was my fault. The center seat SRS sensor was disconnected when I reconnected the battery and tested the pump. Here comes the SRS error code. Ok I knew I'd have to get to the dealer to reset it. But the real problem is I now have a fault code of "Check Stop lights". It seems "both" left and right stop lights don't turn on but the center bar does. All other lights/functions on the entire car are perfect. I checked the fuses and none were blown, so I am suspecting its the relay in the left rear compartent. But I can't find a diagram to tell me which relay is for the brake lights. Or is it possible I may have dislodged one of the connectors under the seats when I worked on the pump? I checked those and found nothing wrong. Just got back fron Volvo and they charged me $75 to reset the SRS code, but they wanted $300 to $400 to figure out the stop light issue. They weren't kidding so I said no thanks. I mean I didn't touch any electrical connectors in that repair except what was needed for the fuel pump. Any suggestions? I even asked Volvo to provide me with the diagram for the rear compartment relays to test the stop light relay (I have a spare), but they said "Oh, we lost that page in the service book". I take that as a pay me my $300 and I'll fix it for you lie.

Let me know. I won't drive the car without the brake lights working.

Thanks.
RacerX is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 08-19-2009
Administrator
 
sulley007's Avatar
 
Join Date: Nov 2008
Posts: 688
Welcome, first what I would do is eliminate the obvious but we probably not the issue - replace the bulb with a brand new one. As crazy as it sounds if both bulbs blew for some issue you could drive yourself nuts on a simple fix. I'd put a meter on the brake light switch up under the dash to make sure you have voltage coming out and check the brake light sockets with a meter to isolate. You could have a faulty brake light switch.

Something else to try is often the electrical contacts on the removable bulb holders get dirty or partially corroded, and then don't carry current well. This can cause the Brake Lights or other Rear lights to fail intermittantly or fail completely.

1. Clean the contacts in the bulb holders and the contact areas on all the bulbs involved.
Use a small piece of emery cloth, or a piece of steel wool.
2. Check the connections where the wiring connects to the lights.
Clean away any corrosion and make sure the contacts are tight.
Sometimes you can use needle nose pliers to gently tighten them.
Replace any corroded wiring.

Let me know how all goes.
sulley007 is offline  
post #3 of 7 (permalink) Old 08-21-2009 Thread Starter
Junior Member
 
Join Date: Aug 2009
Posts: 6
Still no Lights

Thanks for the suggestions, but the contacts are as clean as the day the car rolled out of the factory.

I ended up checking the brake relays and shunt in the rear compartment to no avail. I guess I must have somehow disconnected a connector under the rear seats when I was replacing the fuel pump. Just doesn't seem possible, but I have the wiring diagram now and will double-check them again.

Every other electrical system is unchanged since the fuel pump was installed, and again, the brake lights were working fine before I started on the fuel pump (and the center bar still lights up,just not the side brake lights)

It always seems to be something with these XC 90's.
RacerX is offline  
 
post #4 of 7 (permalink) Old 08-24-2009 Thread Starter
Junior Member
 
Join Date: Aug 2009
Posts: 6
Still no Brake Lights

I was able to secure a copy of the wiring diagram for the XC 90. I have now tried replacing all the fuses relating to the brakes, both bulbs (again), i switched the brake relay out in the rear compartment REM, I have taken out the rear seats again and doubled checked all the connections.

Nothing, zero zip. I still have the upper center bar coming on when the brakes are applied but still not the two outer lights. All other rear lights and entire electrical system in the car is functioning perfectly.

I really don't know where to go from here. I have heard that sometimes the relays need to be "woken up", but I'm not sure how to do that other that replacing it. Would having the rear compartment REM reset do anything and is that possible? Is that something I can do or do I need the dealer to hook up their computer to test all the computers?
RacerX is offline  
post #5 of 7 (permalink) Old 08-24-2009
Administrator
 
sulley007's Avatar
 
Join Date: Nov 2008
Posts: 688
You will need to get a volt meter and start from one end to the other and you will find along the path where the break is.
sulley007 is offline  
post #6 of 7 (permalink) Old 08-25-2009 Thread Starter
Junior Member
 
Join Date: Aug 2009
Posts: 6
Talking Solved - rear brake relay defective

Finally!!!!

After going over every electrical component and connector that I thought I could have damaged when I replaced the fuel pump, plus going through all the fuses, and relays, the last and final check I did was to completely replace the brake relay in the left rear compartment and PROBELM SOLVED!!!

What's really strange is that's where I actually started to look for the problem. I switched another relay (exactly the same) from my fog lights, and tried it in the brake relay location and switched the brake relay over to the fog lights. The fog lights worked but the rear brakes still wouldn't function. So I switched everything back.

Why replacing the brake relay with a completely new one did the trick is another mystery.

But, the long story is, the fuel pump replacement had nothing to do with the brake lights going out as I suspected. How the lights went out coincidently at the same time as the completion of the work on the fuel pump is why I chalk it up to "its a Volvo, what do you expect".

Thanks for sticking with me on this one.

RacerX
RacerX is offline  
post #7 of 7 (permalink) Old 08-26-2009
Administrator
 
sulley007's Avatar
 
Join Date: Nov 2008
Posts: 688
Congrats and thanks for the update! I'm sure it will help others who follow.
sulley007 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Volvo Forums - Volvo Enthusiast Forum - Volvo Community - Volvo Repair forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
240 only when tail lights on brake lights will not work Benedict Volvo 100 and 200 series 4 07-14-2012 11:38 PM
[B]240 only when tail lights on brake lights will not work Benedict Volvo 100 and 200 series 1 03-27-2011 06:41 PM
2004 xc90 front DS o2 replacement vincent12773 Volvo Cross Country and SUV 1 05-03-2010 07:13 PM
bizarre power and engine failure 2004 XC90 bradnightengale Volvo Cross Country and SUV 2 04-20-2009 11:12 AM
XC90 E Brake ? vxc90 General Discussion 2 04-19-2009 11:46 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome