Volvo Forums - Volvo Enthusiast Forum - Volvo Community - Volvo Repair - Reply to Topic
Volvo Cross Country and SUV Volvo XC50, XC60, XC70 and XC90

Thread: 2005 XC90 - no heat(er) Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Volvo Forums - Volvo Enthusiast Forum - Volvo Community - Volvo Repair forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
02-20-2020 03:50 PM
mgdriver
Heater core

I had the same issue with my 2006 XC-70, ended up being the heater core partially blocked. Replaced the core, all good.
01-09-2020 10:32 AM
L76
2005 XC90 - no heat(er)

2005 XC90 V8. Blower works. AC works. No heat though (after engine fully warmed up... still blows cold... regardless of whether AC is on or off). Thoughts?

Thx

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome