Volvo Forums - Volvo Enthusiast Forum - Volvo Community - Volvo Repair - Reply to Topic
Volvo Sedan Volvo S40, S60, S70 and S80

Thread: S40 climate control issue - cycles on & off Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Volvo Forums - Volvo Enthusiast Forum - Volvo Community - Volvo Repair forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
04-27-2010 07:23 PM
sulley007 I'd check to make sure the coolant is full. May need to take to a service center. But if the freon/R12 is low I think it may cause the a/c to not run.



04-22-2010 07:51 PM
don_zielke
S40 climate control issue - cycles on & off

I bought a 2003 Volvo S40 a couple years ago with about 85K miles on it. With the exception of a few typical door dings it's in really nice shape.

Almost as soon as we got it we started to notice an issue with the auto climate control. The A/C would cycle on & off (especially in around-town driving), but would work when switched to manual control. It only happened intermittently at first.

Now, it won't run on auto at all, and most of the time the A/C won't stay on even in manual mode. I really wonder if it's a switch issue, but I'm not sure where to start diagnosing the issue (short of taking it to the dealer). I checked the freon pressure and it's fine, reading right where it should. Any suggestions?

Thanks,
Don Zielke

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome