Volvo Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
the passenger head lamp comes on with the side lights? if i turn the light switch to first position only side lights come on, next position head lamps come on. i think there might be a short or bad connection on passenger side head lamp.had a quick look but found nothing , unpluged bulb and reconnected it, still same ? has anyone had this problem befor ?. 1996 volvo 850 2.5 10 valve non turbo.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #2
ok ignor that last post. its my day running lamps that are on, silly me :) cars running good, done few miles to night. only thing that did happen was when i stopped at shop. went to start it, it went to start but shuddered like it was missing. turned key again, started as normal ? mybe bad earth connection.
 

·
Registered
Joined
·
46 Posts
There are a number of things that can cause a hard hot start. Need to find out if it was just a one time thing or if you start running into it more often. The two likely suspects would be a vacuum leak or coolant temperature sensor that's starting to fail. There are others too but these would be common.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
thanks for that info. done a few more miles in it, gives good mpg around 34 mpg good power from the 2.5 10 valve non turbo. starts first time when cold, and sometimes slow to start when hot. feels like a bad earth mybe, i will look into the vacuum leak or coolant temperature sensor ,
 
1 - 4 of 4 Posts
Top