Volvo Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
My dipstick comes out clean when I check oil, yet when I change oil I get the correct amount of oil.
can someone tell why? is my engine dying soon?
if I have to replace engine can I be able to convert my car to a Turbo engine?
 

·
Registered
Joined
·
330 Posts
If it were buring oil at such an extreme rate, you wouldn't see the car because of all the clouds of blue smoke coming out the tailpipe!
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
1998 V70 oil engine problem

If it were buring oil at such an extreme rate, you wouldn't see the car because of all the clouds of blue smoke coming out the tailpipe!
actually, it is not burning much oil, just a little, you can see smoke only when the car is iddling at red light,otherwise no smoke, just my dipstick comes out with a foam instead of oil lever.
 

·
Registered
Joined
·
330 Posts
Foamy oil is not good.

I'd say it's a head gasket problem, letting coolant into the oil.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #5 ·
I rechecked last weekend, found that there is few drops of oil that come from between head and engine block, probably bad gasket, for the foamy dipstick, I changed oil and refilled oil with one quart of oil stabilizer. so far it is ok. one thing that I hate is that my car lost power and I don't like to be left behind when stopped on red light. check engine light came on this week, I scanned and it showed P0422, main catalyst efficiency below threshold bank 1.
I recently changed main seal about 2 and a half years ago, that is when I had another P0420 code and the car did smoke that time, could this be related to the somoking this time if the seal again is broken?
 

·
Registered
Joined
·
330 Posts
The cat is probably plugged (hence the loss of power) and it's throwing codes (also a possible loss of power) probably from a head gasket leak into the combution chamber causing smoke which will contaminate the convertor.

By 'main seal' I'm assuming you mean a crank seal,which in no way would affect the cat. The leak you noticed between the head and block would be a stong indicator of a possible leak into the head (along with the smoke).

You'll need someone to do a cylinder compression test and a coolant pressure test to confirm the problem. It won't be cheap but there's no choice. A new cat at the same time will restore more lost power.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #7 ·
Thanks for Support, my car gave me hard time until it quit Running, it is still running but with some problem maintaining iddle. so I am looking to get rid of the engine and put in a diferent one with low miles.
if anyone knows somebody selling a good engine 1998 V70 2.4L non turbo please let me know.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #8 ·
Now I have replaced the engine with a better one, 89K
a mechanic who put it in for me is not specialized with Volvos, the shop specialise in Hondas, Nissan, and Isuzu.
after he put in engine, my car does not start, each time they scan ECU, it comes up with new code, first it came with the codes:
P0505 Idle control system malfunction
P1505 Mfr ctrl veh spd idle ctrl, aux inp
P1507 Mfr ctrl veh spd idle ctrl, aux inp
next sca showed:
P0103
I don't remember exactly how the explanation, but it said
Unmettered air High input
then the third scan
P0120 TPS Sens "A" circuit malfunction
P0500 VSS SENSOR MALFUNCTION
p0123 tps sens a CIRCUIT HIGH INPUT
DO YOU THINK ALL THESE THINGS HAVE PROBLEMS, or there may be a wrong connection to those sensors? my car did not have any of those problems before engine was changed except the P0103 wich made the car to cat off itself after start and it seemed like iddle was having problem. but still the car started right on every try.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #9 ·
Updadate

after several weeks of troubles and struggles, I finally got my Volvo V70 back on Street, I replaced engine 170K with a better one 89K, got some diagnostic troubles, car would still not run sometimes not start,
I previousily had a P0103 code, I ordered a brand new Botch MAF sensor, intalled it today, after I put it in, drove the car for road test, the car is like new again, no more troubles for many more miles ahead.
Thanks to every one here on forum who contributed.
:)
 
1 - 9 of 9 Posts
Top