Volvo Forums - Volvo Enthusiast Forum - Volvo Community - Volvo Repair banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
In 'park' the fan's coming on and off, on and off, and it feels like she's going to quit at a red light. So I had a new thermostat, everything else is fine, regularly serviced etc. Mechanic said it had to be engine management system ECU. So I found on, had it fitted, all electrics are a-okay. Engine fab in all respects, but she's still revving up here at there, fan kicking in and out, small surges when driving. Mechanic hasn't got a clue. I love my Viv and no one seems able to help. Has anyone here had a similar/same problem, and what was it in the end? If you can, PLEASE help. By the way, I'm a woman so I may not have explained it very well. Thanks.
 

·
Registered
Joined
·
36 Posts
You say your engine is revving up and down? As in our rpm's are jumping around, while either in park or driving? Because this just happened to my 1987 760 GLE just the other week when I took it to the car wash and sprayed water and engine degreaser under the hood to clean it up... I didn't feel like I had any power and felt my car could die any second. It did this for about 2 days, the thing is i have no idea what caused it... I checked everything and I needed oil, and transmission fluid in which I returned them to normal levels. I doubt the fluids had anything to do with it, but I would guess you have some moisture somewhere where it isn't supposed to be...
has your mechanic checked your air filter, wires to spark plugs, spark plugs etc..
 
1 - 2 of 2 Posts
Top