Volvo Forums - Volvo Enthusiast Forum - Volvo Community - Volvo Repair banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have developed a strange, and rather annoying problem with my lights on my 940.

I was sorting out a switch for the front fog lights as I have a custom made dash, and to get a warning light for when the front fogs are on, I was advised to connect the switch to the relay, and since doing this, the following don't work:

- both sidelights
- RH headlight
- RH high beam
- both front fog lights
- RH tail light
- indicators
- hazards


However, the headlamp, high beam and tail light work on the left side of the car. I've checked the fuses and they're fine.


Any idea on what the issue could be?


Cheers
 

·
Registered
Joined
·
330 Posts
Here's a link to a 740 wiring diagram (closest I could come to a 940 - should be similar) .

I would look at item #115, Bulb Failure Sensor and see if there is a problem there. This senses continuity from most of what you've listed. Check the wiring schematic for other possible problems but they all seem to have this in common.

Get a 12v test light and some patience
 

·
Registered
Joined
·
12 Posts
Bulb failure does not do anything for headlights or fog lights. What relay did you touch.did not say. I say start by undoing whatever you did and put it back the way it was first. Than where do you want the light to come on showing you have fog lights on at. You can always put a led light by the switch to light up when on. If your dash is custom it would be somewhat nice to have it that way. Custom look.
 
1 - 3 of 3 Posts
Top