Volvo Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi all. I just bought my first Volvo today. It's a 2002 V70 2.4T. I got a good deal on it because the instrument panel isn't working, but now I need to figure out how to fix it.

I've done some reading and the chip in the DIM seems to have a design flaw and tends to die, but there also seem to be other things that cause similar symptoms. The dealer I bought the car from seemed to be sure the DIM was the problem but I want to be sure before I start throwing money at it.

None of the gauges work, the info panel on the left does nothing and the two middle ones are not back lit but function. I'm leaning towards shipping it to xemodex for repair. Are there any other options out there are reliable? I don't have the time or money to be trying a bunch of different stuff. Also, I ordered a DICE unit. Should I wait to see what the computer has to say before pulling anything or can we be certain of the culprit without it?
 

·
Registered
Joined
·
1 Posts
Hi all. I just bought my first Volvo today. It's a 2002 V70 2.4T. I got a good deal on it because the instrument panel isn't working, but now I need to figure out how to fix it.

I've done some reading and the chip in the DIM seems to have a design flaw and tends to die, but there also seem to be other things that cause similar symptoms. The dealer I bought the car from seemed to be sure the DIM was the problem but I want to be sure before I start throwing money at it.

None of the gauges work, the info panel on the left does nothing and the two middle ones are not back lit but function. I'm leaning towards shipping it to xemodex for repair. Are there any other options out there are reliable? I don't have the time or money to be trying a bunch of different stuff. Also, I ordered a DICE unit. Should I wait to see what the computer has to say before pulling anything or can we be certain of the culprit without it?
My 2002 V70 is doing the same thing. Today the speedometer and the RPM stopped functioning also. Did you send yours to Xemodex?
 
1 - 2 of 2 Posts
Top