Volvo Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I drove my 04 s60 2.5t car to the store, while on my way to the store, the car surges 3 times. On leaving the store the car started and run for about 10 seconds. This happen several times to the extent that I have to towed the car home. I tried using my CAN OBD II scan tool to retrieve any error code that may be responsible for the engine cutting off immediately after start, but it registered no error code. The check engine light goes on and turn off after a few seconds. Please help with the following

1: why would the engine run for only few second and cut off
2: Why no error code was registered
 

·
Registered
Joined
·
1 Posts
Think you need to isolate: fuel? spark? You can quickly check fuel by finding the valve on the end of the injector rail. It's like a tire valve with a needle. Push the needle down right after trying to start. Does gas squirt out? (Have a rag, etc so it doesn't spray all over the place).. If nothing comes out, can you hear the fuel pump? Do you see RPM's on your OBII reader? Do you have a tach on your car? If no RPM's show, think about the computer not knowing that the engine is turning. (rotation sensor bad etc MAF? PEM? fuel pump relay? Need to narrow it down...
 

·
Registered
Joined
·
16 Posts
exactly what he said, you must narrow it down, also you could try pulling out a spark plug and checking its conditon, they may be fouled, another thing you could try is using a small amount of starting fluid in the throttle body, but only a small amount its very combustable, and try cranking it, if it starts then you probly have and issue with your fuel delivery, maybe a clogged filter bad pump, bad pressure reg, or injectors.
 
1 - 4 of 4 Posts
Top