Volvo Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
The first issue I want to ask about is an abs code 141 which says that it is a faulty pedal sensor, shorted to ground or supply. Ok does that mean that my brake light switch is bad or the wiring to it is bad? Also there is another switch down by the pedal that has vacuum to it and I cant seem to find that switch on parts web sites. Does anyone know what this switch might be?

Next issue is sometimes after getting gas, the car does not want to start. It starts up but shuts off immediately then next time turns over and wont start. Keep trying to start it and let it wait in between and then it finally starts up and runs and doesn't give me any issues. Could it be a fuel tank pressure sensor? I don't know if this vehicle has this sensor or not but it is acting like the Saturn that we had doing the same thing.

My boyfriend and I bought this car and love the car and want to make this our family car and make it very dependable. It has little issues and we just want to try and get them worked out and like I said make it very dependable.
 

·
Registered
Joined
·
46 Posts
There are two switches, one is the brake light the other is the cruise control.

The hard start after fueling ... do you stop when it first clicks off at full or do you stand there and try to round up to the next dollar ??

Do you need to hold the pedal to the floor to get it started or is your foot off the pedal and your just cranking ??
 

Attachments

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
No I don't have to hold the pedal to the floor and it isn't always after fueling. Today I stopped at account and when I got back in my car, it started up and when I put it in gear it died and then wouldn't start. It turned over and then it finally started and then died. It wouldn't stay running. I let it sit for a few minutes and then it started right up and didn't give me any more issues when I stopped at a couple more of my accounts. Then on my way home tonight and I traveled about a couple miles and then the car changed pitch and then started slowing down. I could rev the motor but it wouldn't let me accelerate. Then it just totally died. It would try and turn over but it wouldn't start. Then again I let it sit for a few minutes and then it finally started and I was able to drive the 20 miles home without another incident. We changed the crank position sensor but that didn't fix the issue. Any ideas.
 
1 - 4 of 4 Posts
Top