Volvo Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
My 86 760 GLE Turbo starts to miss, stall, etc once the engine is warmed up, it will usually get me home, but just barely(have had to have it towed from this issue).


It will do this even if you start it and let it warm up just sitting - after it reaches operating temp it will surge a couple times, shutter, miss and stall - starting up is usually not an issue, but I did have one time it wouldn''t.

I have replaced (mostly with used tested parts) the following:

Distributor
MAF
Power Stage
Injector resister pack
pre-heat hose

I have checked all the vacuum lines and wiring.

I thought I had the problem resolved after replacing the Ign. Pwr Stage - I ran the car on a long trip, much of which was mountainous twisty roads, I ran the car hard and it ran flawlessly, got 21 mpg and was a joy - I ran it around home for a couple weeks after the trip and then the problem started on the way home from a car cruise. I replaced the Ign Pwr Stage with another known good one, but the problem still exsists.


I don''t really want to keep throwing parts at it needlessly - what should my next step be.

If you have suggestions of parts to replace - please also tell me where they are located.

I enjoy this car SO much when it is running good - I want to be able to enjoy it without that twisted feeling in the gut every time I take it out.

What is/are my next step/steps?
 

·
Registered
Joined
·
32 Posts
My 86 760 GLE Turbo starts to miss, stall, etc once the engine is warmed up, it will usually get me home, but just barely(have had to have it towed from this issue).


It will do this even if you start it and let it warm up just sitting - after it reaches operating temp it will surge a couple times, shutter, miss and stall - starting up is usually not an issue, but I did have one time it wouldn''t.

I have replaced (mostly with used tested parts) the following:

Distributor
MAF
Power Stage
Injector resister pack
pre-heat hose

I have checked all the vacuum lines and wiring.

I thought I had the problem resolved after replacing the Ign. Pwr Stage - I ran the car on a long trip, much of which was mountainous twisty roads, I ran the car hard and it ran flawlessly, got 21 mpg and was a joy - I ran it around home for a couple weeks after the trip and then the problem started on the way home from a car cruise. I replaced the Ign Pwr Stage with another known good one, but the problem still exsists.


I don''t really want to keep throwing parts at it needlessly - what should my next step be.

If you have suggestions of parts to replace - please also tell me where they are located.

I enjoy this car SO much when it is running good - I want to be able to enjoy it without that twisted feeling in the gut every time I take it out.

What is/are my next step/steps?
hello

Your car is one of the most strong model os volvo:) if you replace the electrical parts the problem is in the fuel system, check de intank and fuel pump this link could you help to find some parts


VOLVO PARTS Volvo 240 parts Volvo 850 parts Volvo 740 parts Volvo 940 parts S70 V70 960 760 S40 V40 S80 140 122 1800 164 and More! Parts Accessories Repair Performance Manuals. Was VolvoWorld

Saludos from Peru
Velez
 
1 - 2 of 2 Posts
Top