Volvo Forums - Volvo Enthusiast Forum - Volvo Community - Volvo Repair banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Long story short, I broke the sunroof on my mom's volvo v40 and bought a replacement assembly (the whole deal; motor, glass, and the tracks etc.) The roof worked fine before, and now that the new one is in, I'm having calibration problems.

Before the roof had 4 major positions: vent (propped in back), closed, open almost all the way (~4in left to go), and then open all the way. Say the roof was in the vent position, from what I recall, I could hold the switch to the open position for as long as I wanted, and all it would do is close the roof. This was the same for all of the positions. If it was closed and I held the open switch it would move to the next position (open almost all the way) and it would never move to the next position until I released the button and pressed it again. This was true for all positions if I recall correctly. I suppose I could call them presets.

Now the roof has no presets, and wont stop in any of the old positions. For instance if the roof is slid all the way back, and I try to close it, it will keep going until it is in vent position with the back propped, and in order to close it I have to fiddle with the switch going back and forth while looking at the top of the roof to make sure it seated correctly, and that is only possible because the switch is not screwed to the car yet. The only thing I see controlling this is that little black box that the two connectors plug into which tucks up to the right of the motor and switch. It has no buttons that I see, but it does have a slightly exposed plastic gear looking knob.

For what it's worth, I have tried the original box, as well as the new one and had the same results.

Any help is greatly appreciated. I leave tomorrow afternoon and this has t be fixed as the car is not mine (I'm just fixing the mess I made).

Thank you for your time,
-Alex
 
1 - 1 of 1 Posts
Top