Volvo Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I have a 98 S70 GLT and I have gone through 2 cooling fans here in the past 3 months???? I can hear the cooling fan relay click on the off within 30 seconds and this is the only time the fan comes on I have slaved in a good relay and it does the same thing the fan only comes on with a full 12 volts. I have jumpered it again and there is no low speed on it for the two speed system?????
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
in city traffic she is running from 210 to 240 then once I start moving in keep it around 210 I will check teh ground. u are talking battery ground or is there other grounds I need to be aware of
 

·
Registered
Joined
·
330 Posts
You should be able to jumper the fan to check what's working.

I would start with the fan directly. Power it directly from the battery and let it run for a while. If this is OK, check the cooling fan relay. It's common to many Volvo models back to 200 & 700 series. Swap one with a friend.

Your final possibilty is to check the coolant sensor is working properly. It's probably a two wire sensor (I'm assuming two stage cooling fan). Check a wiring diagram to be sure (can't find one on-line) and either short one side or the other to ground or ground the two together if it's one speed.

After ground problems, sensors and relays are usual suspects.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
I have jumpered the fan n it works fine I have slaved in a good relay and checked grounds I do not know where the coolant sensor is?????? DOES anyone know where on my 98 S70 GLT??????
 
1 - 6 of 6 Posts
Top