Volvo Forums - Volvo Enthusiast Forum - Volvo Community - Volvo Repair banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
2008 Volvo S60 52,200 miles
The message center suddenly read, "Reduced Engine Performance," and the car went into limp mode. After shutting it off for a considerable time frame, it went off. It has been occurring intermittently for five days. I finally got it to a dealership yesterday. I had been researching the internet on this issue and found it appears to be the ETM/Throttle Body -- a common problem with Volvos in recent years.
The dealership just called and said it is teh Throttle Assembly Actuator. They informed me that Volvo no longer uses ETMs (since 2006) and have been using these Actuators instead. It is $982.15 to fix.
Is anyone else having problems with the ETM replacement - the Actuator????
I am angry and upset. This car is 2000 miles out of warranty. This is obviously an on-going issue. I always dreamed of owning a Volvo....I drove the same car for ten years just so I could afford this freaking car. What a joke! Was I "duped"!
 

·
Moderator
Joined
·
42 Posts
Brooke, you weren't duped. I would recommend you talk to the Service Manager at your Volvo dealer and ask him to attempt some sort of goodwill assistance from Volvo. Have you done your maintenance at the dealer or have you always gone elsewhere for maintenance and now you want Volvo to pay for something that's gone wrong ? As far as it being a common problem, not the case. It was in older years but the 08s have been pretty much problem free.
 

·
Registered
Joined
·
1 Posts
Has anyone aver solved this issue? I have a 2007 S60 seeming to have the same issues. Can’t afford Volvo dealership costs. Supposed reputable mechanic has changed plugs, coil packs, air cleaner and MAF sensor all to no avail. Would love some honest information.
 
1 - 3 of 3 Posts
Top