1994... 940..non-turbo vacuum leak under dash - Volvo Forums - Volvo Enthusiast Forum - Volvo Community - Volvo Repair
Volvo 700, 800 and 900 series Volvo 740, 760, 780, 850, 940 and 960

User Tag List

 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 09-01-2010 Thread Starter
Junior Member
 
Join Date: Sep 2010
Posts: 2
1994... 940..non-turbo vacuum leak under dash

Hi to all,
I have a vacuum leak under the dash, when you accelerate the ac/heater blower slows down or appears to. I think what is happening is when you accelerate, the engine requires more vacuum and there is not enough to hold the dash diaphragm engaged and therefore it reverts to default which is "defrost/floor". I have checked the diaphragms I can see on the drivers side under the dash. The dual one checks OK on one port but unable to hold vacuum on the other one. Disconnected this one (plugged hose) and tried to pull vacuum.
Connected hand held pump to hose on dash side of line check valve.
I can draw about 5 inches of vacuum but it leaks down. Can crimp the line feeding the system under the dash after it is (reduced to new kind of hose) and can draw 25 inches of vac. and it will hold.
I am unable to locate the valve bank under the dash. I have taken the glove box out and it is not under there..
There has to be a valve bank because you have different colors going to each diaphragm.
If someone can point me in the direction of the valve bank in this auto and how to get to it I would greatly appreciate it. By the way this happens only when accelerating , the air stops coming from the dash registers and goes to the floor and defrost vents which is "default for Volvo" Sorry for the long post
katman104

After further reading I am beginning to think I do not have "Climate Control"
I have three controls....."Blower", "Function Selector", "Temperature Dial" and a recirculating button, and AC on/off button. I do not know if I would have a valve bank or not with this setup. All my different color hoses to the diaphragms may be coming from the "Function Selector" switch. Can anyone help me out here? Thanks in advance
Katman104

Last edited by katman104; 09-01-2010 at 04:22 PM. Reason: Another question
katman104 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Volvo Forums - Volvo Enthusiast Forum - Volvo Community - Volvo Repair forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
S70 N/A vacuum line help? madspeed Volvo Sedan 2 05-20-2015 06:47 PM
vacuum hoses and electrical connections 1990 740GL althethird Volvo 700, 800 and 900 series 4 03-23-2010 07:13 AM
1994 850 TURBO: Need a timing belt cover jsellers Volvo 700, 800 and 900 series 0 03-08-2010 09:50 PM
Looking to purchase a 1994 850 TURBO with 55k orig miles jsellers Volvo 700, 800 and 900 series 0 02-10-2010 06:35 PM
1999 v70 XC AWD 2.4 vacuum diagram kmellott Volvo Cross Country and SUV 2 10-07-2009 08:44 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome