2005 XC90 - no heat(er) - Volvo Forums - Volvo Enthusiast Forum - Volvo Community - Volvo Repair
Volvo Cross Country and SUV Volvo XC50, XC60, XC70 and XC90

User Tag List

 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 01-09-2020 Thread Starter
L76
Junior Member
 
Join Date: Jan 2012
Posts: 2
2005 XC90 - no heat(er)

2005 XC90 V8. Blower works. AC works. No heat though (after engine fully warmed up... still blows cold... regardless of whether AC is on or off). Thoughts?

Thx
L76 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 02-20-2020
Junior Member
 
Join Date: May 2013
Posts: 4
Heater core

I had the same issue with my 2006 XC-70, ended up being the heater core partially blocked. Replaced the core, all good.
mgdriver is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Volvo Forums - Volvo Enthusiast Forum - Volvo Community - Volvo Repair forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome