2000 xc70 confounding throttle problem...Help please! - Volvo Forums - Volvo Enthusiast Forum - Volvo Community - Volvo Repair
Volvo Cross Country and SUV Volvo XC50, XC60, XC70 and XC90

User Tag List

 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 1 Week Ago Thread Starter
rfc
Junior Member
 
Join Date: Feb 2020
Posts: 1
2000 xc70 confounding throttle problem...Help please!

2007 xc 70. Late last summer a problem started that once the car warmed up, at about 1500 rpm to 2000 rpm, in any gear, cruise control or not, the car would feel like it's missing big time. Tach hunts wildly back and forth between 1500 and 2000 to 2500 rpm. Replaced coils, misc turbo switches, throttle body...nothing is working. Prefer not to have to spend $1200 on a new ECU. It's definitely temperature related, as I can drive it at 15 degrees F without the problem occurring. Much above that, after the car warms up, it's like riding a bucking bronco.

Is there some master temp sensor the ECU uses that I can cut out of the system (pack with ice, lo?). I've had it in the hands of several veteran Volvo techs; no one can figure it out.

Can anyone here help?

Last edited by rfc; 1 Week Ago at 07:52 PM.
rfc is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Volvo Forums - Volvo Enthusiast Forum - Volvo Community - Volvo Repair forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome