S40 Stalling / Rough Idle after PCV replacement (P0101 code) - Volvo Forums - Volvo Enthusiast Forum - Volvo Community - Volvo Repair
Volvo Sedan Volvo S40, S60, S70 and S80

User Tag List

 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 05-21-2019 Thread Starter
Junior Member
 
Join Date: May 2019
Posts: 1
S40 Stalling / Rough Idle after PCV replacement (P0101 code)

Hello Everyone!

I wanted to know if anyone has an answer to what may be causing an 07 volvo s40 Turbo model to stall intermittently during idle.

Some days it will just sputter a bit then once it warms up it runs great, and wont stall if left idling once warm.

Other days it will stall out, I may have to rev it to around 2000 rpms after starting it back up, then I can drive it but for two minutes usually it sputters a bit.

Almost like the fuel is on, off, on, off then it finally goes good.

I wanted to provide a thread from another forum, where the user has a ton more information, and is experiencing the same issue.

We are both trying to fix this, now roping in multiple forums to make sure we get all of the best minds on this issue.

So Far I have replaced the PCV, Antifreeze in and out line, as well as the antifreeze to the tranny line (They were all leaking), a new antifreeze resiviour (cracked under pressure), and a new mass air flow sensor (Getting a P0101 code, and a system running too rich, and system running to lean codes)

My garage has done a smoke test, but to no resolution.

I am running out of money fast!

I heard it could be a fuel pressure sensor, or a fuel pressure regulator, but I have no idea where that may be in my engine (If you know or can provide pics please help)

The listing to the forum with a ton of information on this issue is here:
https://forums.swedespeed.com/showth...-(p0101)/page6


Please help me as I am out of sick time at work, and if I am even a second late I lose my job. I fear I am going to start it up one of these mornings and it will stall out for good .

(Car has 186,000 miles, but runs like a top when it is running good, 0 rust)

Thanks guys!
07S40Guy is offline  
Sponsored Links
Advertisement
 
Reply

Tags
fuel pressure, idle issues, p0101, s40, stalling

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Volvo Forums - Volvo Enthusiast Forum - Volvo Community - Volvo Repair forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
2005 Volvo S60 T5 Rough idle at cold start tommysayles Volvo Sedan 0 06-16-2013 11:27 PM
S60T5 starts well but very rough idle afterwards and die naelec Volvo Maintenance and Repairs 0 03-07-2013 12:15 PM
2005 S40 T5 Rough Stumbling Idle at Cold Start dawgduo Volvo Sedan 4 11-22-2012 09:58 AM
Car stalling at idle,thick smoke DigitalStealth Volvo 100 and 200 series 1 03-31-2011 01:22 PM
Clogged PCV valve - where is the bugger - volvovolks Volvo Maintenance and Repairs 1 10-03-2008 08:17 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome