Both low beam headlights quit working - Volvo Forums - Volvo Enthusiast Forum - Volvo Community - Volvo Repair
Volvo Sedan Volvo S40, S60, S70 and S80

User Tag List

 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 12-12-2019 Thread Starter
Junior Member
 
Join Date: Dec 2019
Posts: 2
Both low beam headlights quit working

It is my daughters car, which is a 2003 Volvo S60. The high beams and parking lights still work. I checked the fuse and that was good. I went to pull the CEM because I hoped the low beam relay had another of the same type I could swap it with the eliminate the relay. I disconnected the battery and tried pulling the CEM, but it was getting stuck. I gave up for the day and put everything back together and the low beams started working again. Then a day or two later, the low beams went out again? Any idea's? Thanks
Tony Spence is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 12-12-2019
Senior Member
 
Join Date: Oct 2019
Posts: 59
Low beams went out? Just comparing between the Volvo S60 and proton ertiga and saw your post...

Sorrow to NOT drive, but you gotta pay for it
road tax calculator malaysia
Omar Yongt is offline  
post #3 of 4 (permalink) Old 12-18-2019
Junior Member
 
Join Date: Mar 2013
Posts: 4
Hola There, do you test the light module
gmartinms is offline  
 
post #4 of 4 (permalink) Old 12-19-2019 Thread Starter
Junior Member
 
Join Date: Dec 2019
Posts: 2
How do you test the light module? Thanks
Tony Spence is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Volvo Forums - Volvo Enthusiast Forum - Volvo Community - Volvo Repair forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome