Instrument Cluster Help - Volvo Forums - Volvo Enthusiast Forum - Volvo Community - Volvo Repair
Volvo Trucks For drivers and enthusiasts of Volvo trucks

User Tag List

 
LinkBack Thread Tools
post #1 of 10 (permalink) Old 06-04-2009 Thread Starter
Junior Member
 
Join Date: Jun 2009
Location: Smiths Falls,Ontario
Posts: 5
Instrument Cluster Help

I have a VNL 770 with a dead instrument cluster. Does any one have any knowledge of the inner workings of the left circuit board? I have done all the checks of the wiring and checked the soldering of the circuit board connectors. I think the problem lies with the +12 Ign. signal on the left board that turns on the microprocessor. Any help would be appreciated.
Sanford and Sons is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 06-04-2009
Administrator
 
sulley007's Avatar
 
Join Date: Nov 2008
Posts: 688
Can you give us the make/model/year info on your car and where the car is located.



sulley007 is offline  
post #3 of 10 (permalink) Old 06-04-2009 Thread Starter
Junior Member
 
Join Date: Jun 2009
Location: Smiths Falls,Ontario
Posts: 5
Sulley

It is a 1998 Volvo 770 highway tractor with a Detroit S60 engine. I am in Ontario,Canada
Sanford and Sons is offline  
 
post #4 of 10 (permalink) Old 06-05-2009
Administrator
 
sulley007's Avatar
 
Join Date: Nov 2008
Posts: 688
Those had some dash board issue in them. I did some research and unfortunately I can't help you. Sorry. Maybe someone else can.



sulley007 is offline  
post #5 of 10 (permalink) Old 06-29-2009 Thread Starter
Junior Member
 
Join Date: Jun 2009
Location: Smiths Falls,Ontario
Posts: 5
Smile Volvo cluster fixed

I found the problem. Will try the cluster in the truck in the morrning.
Sanford and Sons is offline  
post #6 of 10 (permalink) Old 06-29-2009
Administrator
 
sulley007's Avatar
 
Join Date: Nov 2008
Posts: 688
That is awesome! Post up pics or anything else that might help others in the future.



sulley007 is offline  
post #7 of 10 (permalink) Old 06-29-2009 Thread Starter
Junior Member
 
Join Date: Jun 2009
Location: Smiths Falls,Ontario
Posts: 5
Cluster repair

Quote:
Originally Posted by sulley007 View Post
That is awesome! Post up pics or anything else that might help others in the future.
Sorry.I did not take any pictures as I was not sure of the out come. I had gotten to the point where I was resigned to purchasing a used replacement cluster. So i figured I had nothing to lose by taking a few things apart. The buzzer is not working but it never did since I have had the truck. If I decide to tackle it I will get the camera out and take a few pics. I sure wish someone had schematics for these circuits as it would make troubleshooting a lot easier. You would think that after Volvo was not using a particular circuit they would release it.
Sanford and Sons is offline  
post #8 of 10 (permalink) Old 11-14-2012
Junior Member
 
Join Date: Sep 2012
Posts: 1
I have a 1999 770 ...the gauges all work, just the lights won't come on....any suggestions?
william lowery is offline  
post #9 of 10 (permalink) Old 11-14-2012 Thread Starter
Junior Member
 
Join Date: Jun 2009
Location: Smiths Falls,Ontario
Posts: 5
Is it the cluster illumination lights or the warning lights at the bottom of the cluster?
Sanford and Sons is offline  
Junior Member
 
Join Date: Aug 2020
Posts: 1
Good morning , I had the same problem and i find online this guys , the fix it like new , i am very impressed , it is call Dashboard Instrument Cluster and they have location in Toronto Ontario as well in Florida US
Try them
Joe T is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Volvo Forums - Volvo Enthusiast Forum - Volvo Community - Volvo Repair forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
No low or high beam or IP cluster lites? eallanboggs Volvo Sedan 0 06-25-2010 05:28 PM
cluster Problems cluster Volvo Maintenance and Repairs 0 09-24-2008 09:38 PM
S40 1996 - instrument cluster with no information thaje Volvo Sedan 1 09-03-2008 10:22 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome